Intermittent Connection Timeouts To Vantiv

Incident Report for Creditcall

Resolved

We have observed no further errors.
Posted Mar 20, 2026 - 16:40 UTC

Monitoring

We have observed intermittent timeouts to FACe - Vantiv and Worldpay eCommerce. We are monitoring the situation.
Posted Mar 20, 2026 - 16:19 UTC
This incident affected: Processors - US/Canada (Worldpay / Vantiv (610)).