Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Jul 10, 2023 - 09:38 UTC
Monitoring
Engineers have identified and resolved the issue with WebMIS reports and will continue to monitor its status. If you continue to experience issues, please contact support.
Posted Jul 07, 2023 - 14:56 UTC
Identified
We have identified the issues to be related to WebMIS reports.
Engineers have identified the issue and are working on a resolution.
An update will be provided shortly.
Posted Jul 05, 2023 - 16:44 UTC
This incident affected: Live Platform (Global - WebMIS).