First Data Rapid Connect Settlement delays

Incident Report for Creditcall

Resolved

The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Aug 23, 2026 - 13:27 UTC

Investigating

Due to a service interruption on the First Data Rapid Connect, Merchants may expect a delay in funding
Posted Aug 23, 2026 - 01:15 UTC
This incident affected: Processors - US/Canada (First Data Merchant Solutions (Rapid Connect)).