Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2026 - 15:00 UTC
Scheduled
Please be advised that NMI engineers will be conducting core maintenance on the eKashu product on Wednesday 9th September beginning at approximately 15:00 UTC. This maintenance window should last approximately 2 hours. There is no expected traffic impact, if you experience any issues please contact webmissupport@nmi.com
Posted Sep 09, 2026 - 10:58 UTC
This scheduled maintenance affected: Live Platform (Global - Hosted Payment Page / eKashu).