Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Mar 18, 2023 - 08:24 UTC
Monitoring
We have seen no recent occurrences of this issue and we will continue to monitor in order to confirm resolution. We will provide another update shortly.
Posted Mar 17, 2023 - 18:17 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.
Posted Mar 17, 2023 - 17:11 UTC
This incident affected: Processors - UK/Europe (Elavon (EISOP)).