The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Sep 04, 2024 - 11:06 UTC
Identified
We have identified an issue affecting transactions for some acquirers/processors. The appropriate parties have been informed and are working to resolve. An update will be provided shortly.
Posted Sep 04, 2024 - 10:20 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.