The internal system issue that has affected the settlement of certain Chase Stratus/Salem transactions has now been resolved. The affected transactions were from 17th of June 2025 and 18th of June 2025; these were resubmitted by 15:35 UTC 19th of June 2025. As a result, the associated funding to accounts may have been delayed or otherwise affected.
Posted Jun 19, 2025 - 16:09 UTC
Identified
The internal system issue that caused issue for Chase Stratus transactions in settlement has now been identified and is being resolved. Transactions in the last two days might have been affected. As a result, funding to accounts may be delayed. A further update will be provided shortly with more information.
Posted Jun 19, 2025 - 12:59 UTC
Investigating
An issue has caused a delay in the posting of Chase Stratus transactions to Chase for settlement. As a result, funding to accounts may also be delayed. A further update will be provided shortly with more information.