Intermittent errors

Incident Report for Creditcall

Resolved

The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Dec 02, 2025 - 20:14 UTC

Monitoring

We have seen no recent occurrences of this issue and we will continue to monitor in order to confirm resolution. We will provide another update shortly.
Posted Dec 02, 2025 - 19:47 UTC

Identified

We have identified the issues relating to the elevated error rates and failed capture attempts.

Engineers are working to resolve the issue as soon as possible.
Posted Dec 02, 2025 - 19:00 UTC

Investigating

Our engineering team is currently investigating elevated error rates and failed capture attempts.
Posted Dec 02, 2025 - 18:31 UTC
This incident affected: Live Platform (Global - Authorization Platform).