Service Incident

Incident Report for Creditcall

Resolved

This incident has been resolved.
Posted May 18, 2026 - 23:25 UTC

Monitoring

Declines and timeouts have decreased. Our engineering team is continuing to monitor to ensure ongoing reliability and stable transaction processing.
Posted May 18, 2026 - 23:14 UTC

Investigating

Our engineering team is currently investigating elevated decline rates and timeouts impacting Chase Paymentech Salem and Chase Paymentech Stratus transactions.
Posted May 18, 2026 - 22:55 UTC
This incident affected: Processors - US/Canada (Chase Paymentech (Stratus / Salem), Chase Paymentech (Tandem / Tampa)).