Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Mar 01, 2024 - 14:20 UTC
Monitoring
We have seen no recent occurrences of this issue and we will continue to monitor in order to confirm resolution. We will provide another update shortly.
Posted Mar 01, 2024 - 12:10 UTC
Identified
We have identified an issue affecting transactions for Credorax (ePower). The appropriate parties have been informed and are working to resolve. An update will be provided shortly.
Posted Mar 01, 2024 - 11:42 UTC
This incident affected: Processors - UK/Europe (Credorax (ePower)).