The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Apr 14, 2025 - 21:08 UTC
Monitoring
We have seen no recent occurrences of this issue and we will continue to monitor in order to confirm resolution. We will provide another update shortly.
Posted Apr 14, 2025 - 20:49 UTC
Identified
Chase (JP Morgan) have confirmed that they are experiencing connectivity issues on their Salem/Stratus platform. This is impacting all transactions processed via Chase Salem. Chase have advised they are currently working with their provider to resolve the issue. Updates will be provided when available.
Posted Apr 14, 2025 - 20:38 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.