Connection to Barclays

Incident Report for Creditcall

Resolved

This incident has been resolved.
Posted Feb 14, 2026 - 08:41 UTC

Monitoring

We are currently seeing intermittent approvals and will continue to monitor.
Posted Feb 14, 2026 - 02:19 UTC

Identified

The issue appears to be with the Barclays service
Posted Feb 14, 2026 - 01:52 UTC

Update

We are continuing to investigate this issue.
Posted Feb 14, 2026 - 01:37 UTC

Investigating

We are currently investigating a potential connection issue with Barclays that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result. We are currently investigating and will provide an update as soon as possible
Posted Feb 14, 2026 - 01:29 UTC
This incident affected: Processors - UK/Europe (Barclaycard (APACS)).