Service Incident - Mastercard 3DS2 Authentications
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Jun 13, 2023 - 10:22 UTC
Identified
We're seeing issues when attempting to process Mastercard 3DS2 authentications which may lead to transaction declines.
Mastercard have stated that they're working on a solution and NMI is monitoring the issue.
Posted Jun 12, 2023 - 13:04 UTC