CPS Transaction Incident

Incident Report for Creditcall

Resolved

The issue affecting CPS (Chase Salem/Paymentech) transactions has been resolved.

We observed a period where some transactions were declined or experienced timeouts due to a temporary connection issue with CPS. The connection has since stabilized, and transaction processing is operating normally.

We will continue to monitor the system to ensure ongoing reliability.
Posted Apr 08, 2026 - 04:35 UTC

Investigating

We’re currently investigating an issue causing some CPS (Chase Salem) transactions to be declined or experience timeouts. Our team is actively working to identify the root cause and implement a resolution as quickly as possible.
Posted Apr 08, 2026 - 04:08 UTC
This incident affected: Processors - US/Canada (Chase Paymentech (Stratus / Salem)).