Service Incident
Incident Report for Creditcall
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 13:36 UTC
Monitoring
Creditcall Engineers have identified and resolved the issue with UK processors and will continue to monitor its status. We will provide another update when we have confirmed that it is stable.
Posted Nov 29, 2023 - 10:28 UTC
This incident affected: Live Platform (Global - Authorization Platform, Global - Hosted Payment Page / eKashu, Global - Merchant Plugin for 3-D Secure).