Service Incident

Incident Report for Creditcall

Resolved

The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Sep 10, 2026 - 14:49 UTC

Monitoring

NMI Engineers have identified and resolved the issue with eKashu service and will continue to monitor its status. We will provide another update when we have confirmed that it is stable.
Posted Sep 10, 2026 - 13:14 UTC
This incident affected: Live Platform (Global - Hosted Payment Page / eKashu).