Batch Settlement Delays

Incident Report for Creditcall

Resolved

The settlement delay affecting BarclaycardHiso transactions processed on 19 September has been resolved. The affected settlement file has been successfully resubmitted and accepted. Settlement processing is now proceeding as expected.
Posted Sep 21, 2026 - 13:35 UTC

Identified

We are currently investigating a delay affecting settlement for BarclaycardHiso transactions processed on 19 September. As a result, affected customers may experience delays in funding. We are working with the relevant parties to investigate the issue and will provide further updates as more information becomes available.
Posted Sep 21, 2026 - 09:07 UTC