Service Incident
Incident Report for Creditcall
Resolved
The issue that delayed settlement for some acquirers/processors has now been resolved
Posted Jul 26, 2023 - 10:38 UTC
Monitoring
We are monitoring the issue that has delayed settlement for some acquirers/processors
Posted Jul 26, 2023 - 09:14 UTC
Identified
We have identified the issue that is delaying settlement for some acquirers/processors
Posted Jul 26, 2023 - 09:00 UTC
Investigating
We are currently investigating an issue that is delaying settlement for some acquirers/processors
Posted Jul 26, 2023 - 08:06 UTC
This incident affected: Processors - UK/Europe (AIB Merchant Services (APACS), American Express (APACS), Barclaycard (APACS), Elavon (APACS), First Data Merchant Solutions (APACS), Global Payments (APACS), Lloyds TSB Cardnet (APACS), Worldpay (APACS)).