CardEase Credorax ePower Transaction Processing Issues

Incident Report for Creditcall

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 10:02 UTC

Monitoring

We have implemented a fix for the issue affecting CardEase Credorax ePower transaction processing. Transactions are now processing normally.

We are continuing to monitor the service to ensure processing remains stable.
Posted Aug 25, 2026 - 09:01 UTC

Investigating

We are investigating an issue affecting CardEase Credorax ePower transaction processing. Transactions routed through one processing instance may be declined, while other processing capacity remains operational.

The issue began at approximately 05:00 UTC. Our teams are working to restore normal processing and will provide further updates.
Posted Aug 25, 2026 - 08:21 UTC
This incident affected: Credit Card Processing.