Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems should be back to normal operation. If you continue to have issues, please contact Support.
Posted Dec 08, 2022 - 10:15 UTC
Monitoring
We have identified an issue affecting transactions for some acquirers/processors. The appropriate parties have been informed and are working to resolve. An update will be provided shortly.
Posted Dec 08, 2022 - 10:03 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.
Posted Dec 08, 2022 - 09:48 UTC
This incident affected: Processors - UK/Europe (AIB Merchant Services (APACS), American Express (APACS), Barclaycard (APACS), Elavon (APACS), Global Payments (APACS), Lloyds TSB Cardnet (APACS), Worldpay (APACS)).