Service Incident
Incident Report for Creditcall
Resolved
Global payments have resolved the previously reported service incident and all systems should be back to normal operation. A full investigation of the incident will start and a Service Incident Report (SIR) will be issued in due course to impacted customers. We aim to complete the SIR within 72 hours of the event but the process can take longer.
Posted over 1 year ago. Dec 28, 2017 - 11:59 UTC
Identified
We have identified an issue regarding transactions headed to the Global Payments Platform.
We have contacted the processor and they are aware of the issue and hope to have it resolved in the next 2 hours.
An update will be provided shortly.
Posted over 1 year ago. Dec 28, 2017 - 10:00 UTC