Service Incident
Incident Report for Creditcall
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 22:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2023 - 22:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2023 - 21:13 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.
Posted Feb 06, 2023 - 21:03 UTC
This incident affected: Processors - US/Canada (Chase Paymentech (Tandem / Tampa), Elavon (viaConex), First Data Merchant Solutions (DL Host / Nashville), Global Payments (Greenhouse), TSYS (Sierra)).