Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems are back to normal operation. A full investigation will start, and a Service Incident Report (SIR) will be made available to impacted customers in due course. We aim to complete the SIR within 72 hours of this event.
Posted Mar 29, 2021 - 12:03 UTC
Investigating
We have identified an issue affecting transactions for some acquirers/processors. The appropriate parties have been informed and are working to resolve. An update will be provided shortly.
Posted Mar 29, 2021 - 07:44 UTC
This incident affected: Processors - UK/Europe (Barclaycard (APACS)).