Service Incident
Incident Report for Creditcall
Resolved
We have resolved the previously reported service incident and all systems should be back to normal operation. A full investigation of the incident will start and a Service Incident Report (SIR) will be issued in due course to impacted customers. We aim to complete the SIR within 72 hours of the event but the process can take longer.
Posted 10 months ago. Mar 14, 2018 - 21:42 UTC
Identified
We have identified the issues to be related to: First Data Merchant Solutions (Rapid Connect) Transactions are still processing but there might be an additional delay.
We have contacted the processor regarding this issue
An update will be provided shortly.
Posted 10 months ago. Mar 14, 2018 - 19:47 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the Creditcall Payment Gateway. Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted 10 months ago. Mar 14, 2018 - 19:20 UTC