Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems are back to normal operation.
Posted Jun 17, 2021 - 09:22 UTC
Investigating
We have identified an issue affecting transactions for some acquirers/processors. An update will be provided shortly.
Posted Jun 17, 2021 - 08:59 UTC
This incident affected: Processors - UK/Europe (Credorax (ePower)).