Service Incident
Incident Report for Creditcall
Resolved
We have resolved the previously reported service incident and all systems should be back to normal operation. A full investigation of the incident will start and a Service Incident Report (SIR) will be issued in due course to impacted customers. We aim to complete the SIR within 72 hours of the event but the process can take longer.
Posted about 1 year ago. Apr 10, 2018 - 13:21 UTC
Identified
We have identified the issues to be related to: Elavon EISOP and POSv2
We have contacted the processor regarding this issue
An update will be provided shortly.
Posted about 1 year ago. Apr 10, 2018 - 07:19 UTC