Service Incident - Mastercard
Incident Report for Creditcall
Resolved
The issue previously reported with Mastercard branded cards appears to be now resolved, we will continue to monitor the situation closely.
Posted 10 months ago. Jul 12, 2018 - 19:08 UTC
Investigating
All merchants may be experiencing intermittent declines on Mastercard branded cards. Our support teams are working with acquirers and processors for information on a resolution.
Posted 10 months ago. Jul 12, 2018 - 18:50 UTC
This incident affected: Live Platform (Global - Authorization Platform).