Service Incident - Chase Paymentech (Tampa)
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems are back to normal operation. A full investigation will start, and a Service Incident Report (SIR) will be made available to impacted customers in due course. We aim to complete the SIR within 72 hours of this event.
Posted Oct 09, 2021 - 09:45 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.
Posted Oct 09, 2021 - 09:27 UTC
Identified
We have identified an issue affecting transactions for some Chase Paymentech (Tampa). The appropriate parties have been informed and are working to resolve. An update will be provided shortly.
Posted Oct 09, 2021 - 09:18 UTC
This incident affected: Processors - US/Canada (Chase Paymentech (Tandem / Tampa)).