Service Incident
Incident Report for Creditcall
Resolved
We have resolved the previously reported service incident and all systems should be back to normal operation. A full investigation of the incident will start and a Service Incident Report (SIR) will be issued in due course to impacted customers. We aim to complete the SIR within 72 hours of the event but the process can take longer.
Posted 8 months ago. May 16, 2018 - 12:19 UTC
Identified
We have identified an issue to be related to Spire units
Please perform a TMS update from the unit its self. Contact support regarding any queries.
An update will be provided shortly.
Posted 9 months ago. Apr 15, 2018 - 10:11 UTC