Service Incident
Incident Report for Creditcall
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 21:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2021 - 21:32 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall) . Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted Jan 12, 2021 - 21:24 UTC
This incident affected: Processors - Australia (First Data Merchant Solutions (AS2805) (Galaxy)).