Service Incident
Incident Report for Creditcall
Resolved
We have resolved the previously reported service incident and all systems should be back to normal operation. A full investigation of the incident will start and a Service Incident Report (SIR) will be issued in due course to impacted customers. We aim to complete the SIR within 72 hours of the event but the process can take longer.
Posted 4 months ago. Oct 03, 2018 - 17:06 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the Creditcall Payment Gateway. Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted 4 months ago. Oct 03, 2018 - 16:04 UTC
This incident affected: Processors - US/Canada (Worldpay (ISO8583)).