Service Incident
Incident Report for Creditcall
Resolved
The previously reported service incident is now resolved and all systems are back to normal operation. A full investigation will start, and a Service Incident Report (SIR) will be made available to impacted customers in due course. We aim to complete the SIR within 72 hours of this event.
Posted Mar 29, 2021 - 14:49 UTC
Monitoring
We have seen no recent occurrences of this issue and we will continue to monitor in order to confirm resolution. We will provide another update shortly.
Posted Mar 29, 2021 - 14:41 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the Creditcall Payment Gateway. Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted Mar 29, 2021 - 14:12 UTC
This incident affected: Live Platform (Global - Authorization Platform, Global - Merchant Plugin for 3-D Secure).