Service Incident
Incident Report for Creditcall
Resolved
We have resolved the previously reported service incident and all systems should be back to normal operation.
Posted 3 months ago. Dec 27, 2018 - 22:08 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the Creditcall Payment Gateway. Some customers may be experiencing service issues as a result. Our engineers are working to investigate and resolve the issue.
Posted 3 months ago. Dec 27, 2018 - 21:09 UTC
This incident affected: Processors - US/Canada (Heartland Payment Systems (Portico)).